We are investigating the increase error rate on Google Maps API
Incident Report for Drive Yello
Resolved
The issue is fully resolved and all APIs are operational for the past 35 minutes. We have started receiving errors from Google Maps geocoding from 11 AM - 11:22 AM. This caused performance degradation and an increase of 400 HTTP errors on Quote API when using geocoding functionality. The outage of the Firebase short link API did not have a major effect on the Yello consumer tracking service as it was automatically switched to an internal link. We will implement further failure handling functionality in the mentioned API for better handling of third party incidents. Thank you
Posted Sep 25, 2020 - 12:07 AEST
Monitoring
Google Maps API error rate has dropped and seems to be stable for the past few minutes, affected Yello APIs are fully operational since. The main affected Google Maps APIs that the Yello platform uses are geocoding and Firebase short links API. We will keep monitoring and update this incident with more details.
Posted Sep 25, 2020 - 11:46 AEST
Investigating
We are investigating the increased error rate on Google Maps API, seems Google Maps Geocoding API is affected the most.
Posted Sep 25, 2020 - 11:28 AEST
This incident affected: Yello API (Public Quote API).